LinkedIn
Copied!

Table of Contents

Understanding application migration requirements

Version:

Only available versions of this content are shown in the dropdown

Before you migrate your application, both your environment and application must meet certain requirements. For example, you must be able to download a RAP archive to a file system location with the required available space.

Your environments and applications must meet the following requirements:

  • You have at least two existing Pega Platform environments. These environments can be any combination of sandbox and production environments, and can be on-premises or in the Pega Cloud virtual private cloud (VPC).
  • You can log in to a machine from which you will complete the release process, such as your organization's laptop, workstation, or server.
  • You have a location on a file system with enough available space to store the RAP archives. You must be able to download the RAP archive to this location and upload a RAP archive to another system from this location.
  • You have complied with stated application guideline and guardrail requirements.
  • Your application rule must specify rulesets that have a patch version. Most application rules have the ruleset version in the stack set to 01-01, such as "Ruleset: 01-01". You must change this to specify your rulesets to the patch level of their version, which is "Ruleset: 01-01-01". This is required for your top-level application rule and all built-on applications, except the base PegaRULES built-on application. This application structure gives you greater control over the release of your software, minimizes the impact of the release on application users, and provides for the smoothest recovery path in case of a troubled deployment.
Did you find this content helpful?

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.