Skip to main content
LinkedIn
Copied!

Pega Mobile Client versions end of life, 7.41.7 and earlier, 8.4.x and earlier

 Starting October 1, 2021, Pega Mobile Build Service will stop building selected older versions of the Pega Mobile Client.

Affected versions

Pega Infinity Mobile Client 7.41.5.0 to 7.41.7, inclusive

Pega Infinity Mobile Client 8.0.0 to 8.4.x, inclusive

Pega Mobile Build Service stopped building earlier versions of Pega Mobile Client on June 1, 2020.

Impact

If you are using Pega Mobile Client with standard settings, this event does not affect you. No action is needed.

If you are using Pega Mobile Client and forcing a build on older versions with .pyHCBuildVersion (Pega 8.1 or earlier versions) or ‘Other’ channel (Pega 8.2 or newer versions), you will see the following error message after the attempted build: 

Selected version of Pega Mobile Client is not available.

Suggested Approach

To prevent or recover from the error message, choose the approach for the Pega Platform version that you are running.

Pega 8.1 and earlier versions

On Pega 8.1 and earlier releases, clear .pyHCBuildVersion.

Pega 8.2 and later versions

On Pega 8.2 and later versions, take the following action:

In Mobile Configuration, the Advanced tab, for the option Stop using ‘Other’ building channel, use either the default channel or the ‘legacy’ channel.

Although not recommended, both .pyHCBuildVersion and ‘Other’ channel are still functional. You can enforce building specific versions if you select a supported version, that is, 7.41.8 or 8.5.x or later version.
Did you find this content helpful?

100% found this useful


Related Content

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us