Skip to main content
LinkedIn
Copied!

Running Pega Mobile Client on iOS 15 and iPadOS 15

Apple iOS 15 and iPadOS 15 available on September 20, 2021

On September 20, 2021, Apple will allow you to update your Apple devices to the iOS 15 and iPadOS 15. These new operating systems enforce the system checks for a new, more secure app signature format while installing or running the apps.

Pega Mobile Client versions affected
Explanation
Impact
Actions to take
Best practices

Pega Mobile Client versions affected

Apps built with Pega Mobile Client versions older than 8.5.308, including apps built with Pega Mobile Client 7.x, need to be updated to run on iOS 15. 

Explanation

All iPhone and iPad devices updated to iOS and iPadOS 15 will not allow installing and running any apps that are built with Pega Mobile Client versions older than 8.5.308. The following alert is displayed when you attempt to start the app:

App Needs to Be Updated. The developer of this app needs to update it to work with this version of iOS.

Impact

Apps that have not been updated for a long time will stop working after an iPhone or iPad is updated to iOS 15 or iPadOS 15.

If you are distributing your apps with the Apple Enterprise Developer Program, you must act to support the installation and running of your apps on iOS 15 or iPadOS 15.

If you are distributing apps through the Apple App Store, no action is needed.

Actions to take

Pega Mobile Client 8.2.100 to 8.5.307
Pega Mobile Client prior to 8.2.100, Pega Mobile Client 7.x, or unable to rebuild app on newer version

Pega Mobile Client 8.2.100 to 8.5.307

When using Pega Mobile Client in a version from 8.2.100 to 8.5.307, rebuild and redeploy an iOS app with a version newer than 8.5.308. The rebuilt app will be signed using the new signature format and will be able to run on the newest Apple operating systems.

Pega Mobile Client prior to 8.2.100, Pega Mobile Client 7.x, or unable to rebuild app on newer version

When using Pega Mobile Client in a version prior to 8.2.100 or if you cannot rebuild the app using the newer version, you need to manually re-sign the application to keep it working on iOS 15.

Perform the steps on a computer using MacOS 10.14 or newer version:

1. Download the current iOS application IPA file (.ipa) from the Mobile Channel. 

2. Change the extension of the downloaded file from “ipa” to “zip”. 

3. Unzip file contents and locate the “.app” bundle. 

4. Ensure that the certificate used for code-signing the app is present in your MacOS Keychain 

5. Invoke the following command:  

codesign -s "Your Codesign Identity" -f --preserve-metadata /path/to/MyApp.app 

6. Verify that the app is correctly signed by invoking the following command: 

codesign -dvvvvv /path/to/MyApp.app 

In the command output locate the following lines: 

Page size=4096 

    -5=de7463c7abc18ed03bba7c74835b7f417d7147780962671f756e016eb78053a1 

    -4=0000000000000000000000000000000000000000000000000000000000000000 

    -3=3947480e89a2682b87a901006a5d8dc799ed41296d4f0959ba1ea151beb19152 

    -2=9c1c6c7ca7d1c838f4e9df538f20ded948c702b4d8195016bc89d2d59892508f 

If -5 contains a value and -7 has a zero value or is not present at all, then you are required to re-sign your app including the DER entitlements.

To re-sign your app, invoke the following command: 

codesign -s "Your Codesign Identity" -f --preserve-metadata --generate-entitlement-der /path/to/MyApp.app 

7. Zip the file and change its extension back to “ipa”. Pay attention to the name of the folder enclosing the ".app" bundle. It should always be called "Payload". 

For more information, see Using the Latest Code Signature Format

Best practices

Do not upgrade immediately: Perform regression tests first.

For all Pega Mobility users
For users with private stores and managed devices
For users with BYOD strategies

For all Pega Mobility users

All Pega Mobility users should defer upgrading to iOS 15 or iPadOS 15 until completion of a comprehensive regression test of their apps on iOS 15 and iPadOS 15. 

For users with private stores and managed devices

Pega Mobility users with private stores and managed devices should defer upgrading to iOS 15 or iPadOS 15 until your group has passed regression tests on iOS 15 and iPadOS 15 internally. 

For users with BYOD strategies

Pega Mobility users with BYOD strategies should contact your users and inform them not to upgrade to iOS 15 or iPadOS 15 until you have certified that the new operating system works. 

 

Suggest Edit
Did you find this content helpful?

100% found this useful


Related Content

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us