Table of Contents

Article

Troubleshooting: Integer value displayed as text value in properties (upgrade regression)

After upgrading from PRPC 6.1 SP2 to PRPC 6.3 SP1, you observe that property values specified as Integer display as Text values in all environments running PRPC 6.3 SP1. After reviewing the example scenario, follow the suggested approach to work around this regression issue.

Scenario

This example illustrates the problem.

  1. Create a section that contains two Integer fields.
  2. Specify one field with Edit OptionRead Only.
    Section layout specifies Integer field Read Only.
  3. Specify the other field with Edit Option Auto.
    Section layout specifies Integer field Auto.
  4. Create a flow to run.
    Flow diagram to test the section Integer fields.
  5. Notice that the Integer - Read only field displays one comma in the integer, while the Integer -Auto field displays no comma. This is the root of the regression problem.
    Read-only integer has one comma. Auto integer has no comma.

Explanation

The pxInteger control contains a column for read-only formatting that includes the option for the Thousands Separator, which is the comma.

By default, this option is set to Yes. If you change this option to No, no comma displays as the Thousands Separator.

Suggested approach

To work around this problem, complete these steps:

  1. Open the pxInteger control for editing.
  2. In the Format section, the Separators field, click No to remove commas as the Thousands Separator for Integer values.
    .Section Layout with control pxInteger Format Separators set to No.

Published November 6, 2014 — Updated October 2, 2015

Related Content

Have a question? Get answers now.

Visit the Pega Support Community to ask questions, engage in discussions, and help others.