Skip to main content
circle-square
Outline Circle
square-square
Little Circle
square-square
Little Circle

Published Release Notes

Find release notes for the selected Pega Version and Capability.

Browse resolved issues for Platform releases.

Geolocation tracking for the latest mobile client

Valid from Pega Version 8

The latest version of Pega Mobile Client™ now supports geolocation tracking for offline-enabled mobile apps. You can enable constant tracking when users work on specific cases from their worklists. This enhancement helps audit the trail of the case and increase the efficiency of your mobile users. For example, dispatchers at headquarters can track the routes of field workers and more effectively assign them tasks based on their current location.

For more information, see Tracking mobile users based on geolocation data.

Flow rules not supported in IE8

Valid from Pega Version 7.1.1

In versions prior to 7.1.2, flow rules do not open in Internet Explorer 8 (IE8). Upgrade your system to the latest version of PRPC or access flows from another supported browser.

Word merge support with Microsoft Silverlight plug-in

Valid from Pega Version 7.1.3

PRPC features that integrate with the Word merge capability are now cross-browser. ActiveX controls (which are only compatible with IE) have been replaced with Microsoft Silverlight. This plug-in must be downloaded separately from Microsoft, as it is not shipped with PRPC.

Some common PRPC features affected by this change include the Application Document Wizard, App Profile, Specifications Landing Page, Specification form, and Case Type Landing Page.

Prior to using these features, Users of PRPC 7.1.3 need to set up their client system(s) as follows:

1. Install Silverlight plug-in

Follow the PRPC prompt to install Silverlight when you attempt to use the Word merge feature:

Silverlight1.jpg

Or download package directly: www.microsoft.com/silverlight/

2. Install PRPC prerequisites

Microsoft Internet Explorer (IE) browsers automatically detect the need for PRPC prerequisites and will prompt for install:

Silverlight2.jpg

Non-IE browsers will load a pop-up window when the user attempts to use the Word merge feature.  Use the link to manually download PRPC prerequisites:

Silverlight3.jpg

Extract the .zip file, execute setup.exe and follow the install wizard:

Silverlight4.jpg

Administrators setting up multiple clients at once may refer to the pzSLpreReqs.cab available in the PRPC 7.1.3 resource kit.

3. Restart browser

Log out of PRPC, close all open sessions and restart your browser.

The PRPC feature integrated with Word merge is now ready for use; Silverlight prompts are no longer displayed.

4. Troubleshooting

Silverlight installation requires access to your file system and a registry setting update to “trust” the associated Verisign certificate.  Contact your administrator if you encounter any security or permission errors during this process.

While Silverlight is cross-browser, it is not fully cross-platform.  Mac users may use Word merge features in Chrome via Parallels.

See the PRPC Developer Help for more information on browser setup requirements.

Organization Setup superseded by New Application Wizard

Valid from Pega Version 7.1.3

The Organization Setup Wizard has been retired in PRPC 7.1.3.  This feature was previously launched from the Designer Studio > Org & Security > Organization > Organization Setup menu. Users are encouraged to run the New Application Wizard (also known as Application Express) instead:

NewAppWizard.jpg

This tool quickly generates an application along with all of the artifacts previously offered by the Organization Setup Wizard. This includes, but is not limited to, the class hierarchy, application rule, organization/division/unit rules, and all relevant data instances.

See the following PDN article for more details on the New Application Wizard:

Create new applications quickly and easily with Application Express

Enabling security policies now requires current password

Valid from Pega Version 7.1.3

As part of Pega’s initiative to protect against malicious attacks, the change password dialog has been enhanced.  When Security Policies have been enabled for your system, new users or those with expired passwords will now be prompted for both their existing password as well as their desired new password.

For more details, review the Designer Studio > System > Settings > Security Policies landing page.

Supported JDBC drivers

Valid from Pega Version 7.1.1

Pega 7.1.1 supports Java 6 and Java 7 SDKs only. Ensure that the JDBC driver you are using supports those versions of Java. See your database installation or upgrade documentation for additional information.

Database Java 6 Java 7
Oracle ojdbc6.jar ojdbc7.jar
MSQL sqljdbc4.jar sqljdbc4.jar
DB2 LUW db2jcc4.jar db2jcc4.jar
DB2 z/OS* db2jcc4.jar or jdb2jcc.jar** db2jcc4.jar
PostgreSQL postgresql-9.1-903.jdbc4.jar*** postgresql-9.1-903.jdbc4.jar

* JDBC drivers are only available from the DB2 for z/OS product. Additionally, you need db2jcc_license_cisuz.jar in the same directory as db2jcc4.jar.

** The db2jcc.jar has been deprecated and may not be supported in future releases.

*** This .jar file is required for PostgreSQL version 9.1.x.

Required Oracle optimization parameter

Valid from Pega Version 7.1.3

To optimize performance, set the Oracle parameter optimizer_index_cost_adj to a value between 20 and 25. If this value is not set, the system can run exceedingly slowly, potentially blocking users from login.

Turn off saved connections in WebLogic

Valid from Pega Version 7.1.1

PRPC caches connections in thread-local storage. When using a WebLogic application server, set database/savedconnections to FALSE to avoid incorrectly saved, container-managed transactions. You can make this update through JNDI settings or by adding an entry to the prconfig.xml, for example:

<env name="database/savedconnections" value="false" />

Remove JVM settings from prior installations

Valid from Pega Version 7.1.1

JVM memory settings ​defined in the setupDatabase.properties file to support a prior installation need to be removed. 

Memory settings are now handled by the installation program. Duplicating these settings may cause installation or upgrade failures. 

Automated Unit Testing is unavailable

Valid from Pega Version 7.1.1

Automated Unit Testing (AUT) is unavailable in 7.1.1 - 7.1.5.

Starting in 7.1.6, users can access AUT features from supported browser versions of IE.

All Pega product release notes can be found on their product pages.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us