Skip to main content
circle-square
Outline Circle
square-square
Little Circle
square-square
Little Circle

Resolved Issues

View the resolved issues for a specific Platform release.

Go to download resolved issues by patch release.

Browse release notes for a selected Pega Version.

NOTE: Enter just the SR ID number in order to find the associated Support Request.

INC-143121 · Issue 610732

Timeout for loading predictors made configurable

Resolved in Pega Version 8.3.6

When using an extremely large number of predictors, the Report definition pzADMPredictorsFilter was suffering timeouts due to the time for loading predictors from the database exceeding the time threshold allowed. This has been resolved by marking the rule as editable to allow custom setting of the threshold according to need.

INC-148899 · Issue 615702

Adaptive models update correctly

Resolved in Pega Version 8.3.6

Some models had the recorded responses column updated, but the models (number of Positive, Negative and Processed Responses) were not updated. Investigation showed that deleting the modelRuleConfiguration through the stateManager/client did not delete modelFactories related to the configuration. If a new configuration came in with a different algorithm, the update issue occurred. This has been resolved by reseting the configuration according to its factory in that specific case.

INC-155822 · Issue 618267

Locking added to avoid null pointer error for auto-populate property

Resolved in Pega Version 8.3.6

After configuring the auto populate property "OrgProduct" which referred to a data page, the system experiencing heavy load led to the property not getting properly initialized. This resulted in a WrongModeException and NullPointerException. To resolve this, the system has been updated to lock the requestor when Queue Processors execute their activity. This will prevent race conditions and concurrent modifications if other threads are accessing the same requestor.

INC-157629 · Issue 626633

Duplicate key exception resolved for adaptive model

Resolved in Pega Version 8.3.6

During the model snapshot update, a DuplicateKeyException was generated while trying to insert a record in to the predictor table. This did not affect the model's learning, but did appear ion the model monitoring report. This was traced to a local scenario of having the same outcome values defined on the model with different cases (Accept and accept). All predictors used in an Adaptive model are inserted into the model monitoring tables as a part of the monitoring job: because the monitoring tables are not case sensitive, this lead to a unique constraint exception since there were multiple IH predictors with the same name. To resolve this, validation has been added which will skip adding duplicates from new responses.

INC-160331 · Issue 628710

ML model continue tag error changed to debug logging

Resolved in Pega Version 8.3.6

Log entries were seen indicating "The continue tag is found without a start tag for window Line1 1234567890 in text". This appeared to be coming from the MLCommand java class. Investigation showed this occurred when the ML model believed a portion of the text (token) was a continuation of the entity because it has not found the starting part of the entity. This situation is not currently treated as a valid output, so an update has been made to change the logging level from error to debug for this case.

SR-69015 · Issue 619995

Unescaping characters implemented for expressions

Resolved in Pega Version 8.3.6, Resolved in Pega Version 8.4.4, Resolved in Pega Version 8.5.3, Resolved in Pega Version 8.6

An issue where expression builder statements were evaluated differently at runtime than at testing has been resolved. Pega Platform expressions with String literals (that is, sequences of characters enclosed in quotation marks) now unescape characters in strategy shapes such as Set Property or Filter.

SR-133183 · Issue 205535

Fixed flow line distortion in Process Modeler

Resolved in Pega Version 7.1.9

When clicking through to a subprocess from a parent flow (by clicking the + sign in the blue subprocess shape), flow lines in the subprocess were shown in a distorted fashion. When opening the same flow in a separate tab (by right clicking the blue subprocess shape and selecting Open Flow) the flow lines were correctly painted. This was an issue caused by the different renderings of the flow depending on whether there was a click through to it (with the + on the parent flow?s subprocess shape), or the subflow was opened in a separate tab (with open Flow). After the Process Modeler saved and checked-in the flow, the connector lines were re-drawn in ways that were non-intuitive and hard to interpret due to the edge routing in PM being calculated off incorrect input data that was taking into account shapes that were not represented on the screen. To fix this, the system now ensures the edges are routed without taking into account any shapes not represented on the canvas.

SR-133184 · Issue 203710

Fixed flow line distortion in Process Modeler

Resolved in Pega Version 7.1.9

When clicking through to a subprocess from a parent flow (by clicking the + sign in the blue subprocess shape), flow lines in the subprocess were shown in a distorted fashion. When opening the same flow in a separate tab (by right clicking the blue subprocess shape and selecting Open Flow) the flow lines were correctly painted. This was an issue caused by the different renderings of the flow depending on whether there was a click through to it (with the + on the parent flow?s subprocess shape), or the subflow was opened in a separate tab (with open Flow). After the Process Modeler saved and checked-in the flow, the connector lines were re-drawn in ways that were non-intuitive and hard to interpret due to the edge routing in PM being calculated off incorrect input data that was taking into account shapes that were not represented on the screen. To fix this, the system now ensures the edges are routed without taking into account any shapes not represented on the canvas.

SR-A1705 · Issue 205449

Fixed scrumboard intermittent failure

Resolved in Pega Version 7.1.9

After upgrading, it was seen that the scrumboard would intermittently fail to load, partially displaying and then hanging if the columns did not fit within the window boundaries due to the number of elements. This was traced to an error in the functionality that resizes parts of the scrumboard, and has been fixed.

SR-A4995 · Issue 213355

Fixed flow line distortion in Process Modeler

Resolved in Pega Version 7.1.9

When clicking through to a subprocess from a parent flow (by clicking the + sign in the blue subprocess shape), flow lines in the subprocess were shown in a distorted fashion. When opening the same flow in a separate tab (by right clicking the blue subprocess shape and selecting Open Flow) the flow lines were correctly painted. This was an issue caused by the different renderings of the flow depending on whether there was a click through to it (with the + on the parent flow?s subprocess shape), or the subflow was opened in a separate tab (with open Flow). After the Process Modeler saved and checked-in the flow, the connector lines were re-drawn in ways that were non-intuitive and hard to interpret due to the edge routing in PM being calculated off incorrect input data that was taking into account shapes that were not represented on the screen. To fix this, the system now ensures the edges are routed without taking into account any shapes not represented on the canvas.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us