This content has been archived and is no longer being maintained.

Table of Contents

Article

Troubleshooting: Avoid Smart Quote character when pasting Microsoft Word text into rule forms

Symptom

If text that you copy from Microsoft Word into Decision Tree form and other rule forms include Smart Quotes, errors may result. 

For example, use of Smart Quotes (the curved, formatted quote symbol) in a Harness or HTML rule can result in unwanted blanks appearing in the display.

Similarly, using Smart Quote characters in a decision tree rule can foul the rule's logic, causing incorrect decision results. 

Solution

When pasting text into the Decision Tree form or other rule forms , ensure that any quotation marks included in the text are unformatted quotes (rather than Smart Quotes). 

You can disable a setting in Microsoft Word so that Smart Quotes are not automatically added to documents:

  1. Open Microsoft Word.
  2. Select Tools from the Word toolbar.
  3. Select AutoCorrect Options.
  4. Select the AutoFormat tab.
  5. Deselect the Replace Straight quotes with Smart quotes option.
  6. Select the AutoFormat As You Type tab.
  7. Deselect the Replace as you type Straight quotes with Smart quotes option.
  8. After deselecting both options, click OK.
  9. Close Word.

Tags:

Published August 6, 2004 — Updated November 15, 2015

Have a question? Get answers now.

Visit the Pega Support Community to ask questions, engage in discussions, and help others.