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Support Article

Slow performance after upgrade to Pega 7.1.8

SA-19043

Summary



The system runs slowly after an upgrade to Pega 7.1.8.

Error Messages



Not Applicable

Steps to Reproduce

  1. Upgrade the system to Pega 7.1.8.
  2. Perform a task on the portal.

Root Cause



A defect in Pegasystems’ code or rules

The agentName is sent as null to the stored procedure sppr_sys_reservequeueitem_b while de-queuing during incremental indexing; therefore, the indexes are not generated. In DistributedIndexerAgent and SystemWorkIndexerAgent, where the system gets the queueIterator object, the system sends the className only and does not send the appropriate agent name. Hence, a null value is sent from within the engine to this stored procedure. Both the agentName and the class name need to be sent when retrieving an instance of queueIterator.


Resolution



Choose the solution that works best for you:
  • Apply HFix-25805 for Pega 7.1.8.
  • Update or upgrade to Pega 7.2.1.
  • Request a hotfix for Pega 7.1.7, Pega 7.1.9, or Pega 7.2.

Apply HFix-25805 for Pega 7.1.8
Apply HFix-25805. Be sure to complete the pre-installation and post-installation steps.

Pre-installation steps for HFix-25805
Before installing the hotfix, ensure that the indexes on the table pr_sys_queue_ftsindexer are the same as the Pega-provided indexes.
Run the following DDL to prevent slow performance.
Include the following indexes and index columns:

Drop index pr_sys_queue_ftsindexer_index1;
Drop index pr_sys_queue_ftsindexer_index2;

CREATE INDEX pr_sys_queue_ftsindexer_index1
ON pr_sys_queue_ftsindexer
(
pyItemStatus asc,pyAgentName asc,pyMinimumDateTimeForProcessing
asc,pzInsKey asc
);

CREATE INDEX pr_sys_queue_ftsindexer_index2
ON pr_sys_queue_ftsindexer
(
pyItemId asc,pyItemStatus asc,pxProcessingNodeId asc
);


Post-installation steps
for HFix-25805

Because the defect might have caused a large backlog in queue tables for indexing, you must run a one-time full-text-search index and truncate the index tables to clean up the backlog.

  1. Disable the FTSIncrementalIndexer agent that incrementally updates the search index files as changes are made to RULE-, DATA-, or WORK- (or all) instances.
  2. Truncate the table pr_sys_queue_ftsindexer. (This is the table associated with the class System-Queue-FTSIncrementalIndexer.)
  3. Submit the full-text search indexes on RULE-, DATA-, and WORK- if they were previously enabled.
  4. Re-enable the FTSIncrementalIndexer agent.

Update or upgrade to Pega 7.2.1 (recommended approach)
Pega 7.1.8 HFix-25805 is delivered in Pega 7.2.1.
Therefore, you can update or upgrade to Pega 7.2.1.

Request a hotfix for Pega 7.1.7, Pega 7.1.9, or Pega 7.2
If you do not want to update or upgrade your Pega 7 deployment, request a hotfix for Pega 7.1.7, Pega 7.1.9, or Pega 7.2.
To obtain the hotfix that meets the needs of your Pega environment and your issue, create a Support Request (SR), following these steps:

  1. Go to My Support Portal, https://pdn.pega.com/support/my-support-portal.
  2. In the Support Requests default view, click Create to create a new Support Request.
  3. In the Request Type field, select Product Defect because you are requesting a new hotfix for the release that you are using, either Pega 7.1.7, Pega 7.1.9, or Pega 7.2.
  4. In the Detailed Description, describe your problem and refer to this Support Article, SA-19043, https://pdn.pega.com/support-articles/system-running-slow-after-upgrading-718.
  5. Complete all the other fields of the SR form as required.

Published April 18, 2017 - Updated October 8, 2020

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