Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

500 Threads spawned on PegaRULES Elastic search

SA-16235

Summary

Environment performance declines. As a result of subsequent analysis of the problem, a marked increase in Java threads is observed within the JVM.
 

Error Messages

The following error message is observed in the systemout logfile:

3XMTHREADINFO "RcvThread: [email protected] [qmid=<HOSTNAME>,fap=10,channel=<CHANNELNAME> ,ccsid=1208,sharecnv=10,hbint=300,peer=/<IPADDRESS>(1414),localport=36835,ssl=no]" J9VMThread:0x000000000524C000, j9thread_t:0x000003FF60F32420, java/lang/Thread:0x0000000123A6F140, state:R, prio=5
3XMJAVALTHREAD (java/lang/Thread getId:0x8B66B, isDaemon:true)
3XMTHREADINFO1 (native thread ID:0x7BE2, native priority:0x5, native policy:UNKNOWN)
3XMTHREADINFO2 (native stack address range from:0x000003FF6468F000, to:0x000003FF646CF000, size:0x40000)
3XMTHREADINFO3 Java callstack:
4XESTACKTRACE at java/net/SocketInputStream.socketRead0(Native Method)
4XESTACKTRACE at java/net/SocketInputStream.read(SocketInputStream.java:140(Compiled Code))
4XESTACKTRACE at com/ibm/mq/jmqi/remote/internal/RemoteTCPConnection.receive(RemoteTCPConnection.java:1505(Compiled Code))
4XESTACKTRACE at com/ibm/mq/jmqi/remote/internal/RemoteRcvThread.receiveBuffer(RemoteRcvThread.java:804(Compiled Code))
4XESTACKTRACE at com/ibm/mq/jmqi/remote/internal/RemoteRcvThread.receiveOneTSH(RemoteRcvThread.java:768(Compiled

Steps to Reproduce

There is no specific use case to replicate this behavior.
 

Root Cause

The source of these threads has been traced back to the Pega Process Commander ElasticSearch functionality.
 

Resolution

To resolve this issue, without employing ElasticSearch functonality, the functionality is disabled using the following procedure:

Update the Process Commander Dynamic System Settings (DSS)

Add the following switches to DSS:

indexing/distributed/search_enabled - false
indexing/distributed/index_enabled – false
indexing/distributed/enabled – false

NOTE: In the Search landing page, uncheck the checkbox titled “ENABLE INDEXING”.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us