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Support Article

7.1.8 DSM Update Migrate Propositions to Decision Data Records

SA-11807

Summary



As part of the update from 7.1.7 (ML7) and NBAM 7.12 to 7.1.8 (ML8) the propositions previously held as data can be converted to Decision Data Records and thereby subject to revision management.

The “Convert groups” wizard in Proposition Management landing page is currently failing and error can be seen in the log file

The error is consistent whether we try to convert 1 or many propositions. It is not clear whether the issue is with the wizard or something omitted from the ML8 update.


Error Messages



2015-06-23 11:53:05,846 [ http-8080-1] [TABTHREAD1] [ ] [ XXXXXXXXX:01.01.01] (CreateRecord._baseclass.Action) ERROR localhost|127.0.0.1 [email protected] - com.pega.pegarules.pub.runtime.ActivityTerminateException: This is a singleton exception object and the stack trace below does NOT reflect the actual point of failure. To see the actual trace, set Initialization/UniqueActivityTerminateExceptions = true
2015-06-23 11:53:07,497 [ http-8080-1] [TABTHREAD1] [ ] [ XXXXXXXXX:01.01.01] (CreateRecord._baseclass.Action) ERROR localhost|127.0.0.1 [email protected] - com.pega.pegarules.pub.runtime.ActivityTerminateException: This is a singleton exception object and the stack trace below does NOT reflect the actual point of failure. To see the actual trace, set Initialization/UniqueActivityTerminateExceptions = true


Steps to Reproduce



Update to ML8 including DSM
Run the “Convert groups” wizard in Proposition Management landing page.


Root Cause



The root cause of this problem is a defect in customer application code/rules.
After analysing the tracer it was noticed that an ootb activity ‘pzCheckForFinalConflict’ was privately checkout in the developer’s ruleset.
It was also noticed that after this activity, the execution abruptly ends and the parent calling activities does not go on to the next step, For ex,

 
  1. CheckAvailability activity did not continue to step 7 (after step 6) and just exits.
  2. KeyValidate activity did not continue to step 4 and so on.



Resolution



This issue is resolved through the following local change:
Deleted the privately checkout ‘pzCheckForFinalConflict’ activity to resolve the problem.

 

Published July 3, 2015 - Updated October 8, 2020

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