Support Article
Accept and Cancel buttons in the screen pop up do not work
SA-58050
Summary
The Accept and Cancel buttons in the screen pop up do not work.
The expected behavior is, on clicking the buttons, a new tab should launch with the newly created work item. Instead, the screen does not change.
Error Messages
Not Applicable.
Steps to Reproduce
- Launch the application
- Receive a call. A screen pop up displays.
- Click the Accept or Cancel button on the screen pop up
Root Cause
An issue in the custom application code or rules. A customized copy of an older control rule, AppPopCallButtons, was used in a newer portal that was not designed for the older control.
Resolution
Perform the following local-change:Use the standard Pega platform controls, which are configured similar to those in the out-of-the box PegaCS CallToasterPop section rule, to perform the Accept and Cancel actions.
Published July 23, 2018 - Updated December 2, 2021
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