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Support Article

Accounts tab and Contacts tab data not populated for remote case

SA-20700

Summary



User reported that while creating the interaction, the Accounts and Contacts data is displayed, but while creating remote case (service case) the Accounts and Contacts data is not displayed.

Error Messages



Not Applicable

Steps to Reproduce



1. Create one interaction through phone call. 

2. Check Accounts and Contacts tab.

3. Create remote case through Add task.

4. Check Accounts and Contacts tab - Data coming through repeat grid are missing.


Root Cause



Two named pages were present on the Interaction thread but not on the service case thread on clipboard. 

This is a backwards compatibility defect in Pegasystems’ code or rules. It was found that the Contact and Account pages were custom created top-level named pages. Pega recommends use of data pages and this was not done due to oversight during the upgrade. 

Resolution



Pega 7 recommends use of data pages and all custom user/top-level named pages must be converted to data pages to prevent issue in the long-term and to leverage the advantages data pages have to offer.

A workaround is to use the “MovePageToRequestorScope” function to move the top-level named pages to requestor scope. This resolves the issue by making the pages available across threads (requestor scope). However, it must be noted that this should be done if ONLY one interaction is active at any time. Also, the openPortal pages should be removed during wrapup. 

Published March 12, 2016 - Updated December 2, 2021

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