Support Article
Action outside the current transaction is not allowed
SA-19794
Summary
An error occurred when an assignment was submitted. The error occurred only on Case Worker Portal and not on Case Manager Portal. Transaction ID mismatch errors were seen in the PegaRULES logs.
Error Messages
This action is not allowed as it is outside the current transaction.
Steps to Reproduce
Start Case Worker Portal, and submit the assignment.
Root Cause
The Submit buttons present in the out-of-the-box section rule, pyCaseActionAreaButtons, were customized. A section refresh action was configured after Finish Assignment. This is the root cause. Finish Assignment submits the assignment and refreshes the section.
Resolution
Perform the following local-change:
Remove the Section Refresh action on Action tab of the Submit button's property panel in pyCaseActionAreaButtons section rule.
Published February 26, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.