Skip to main content

Support Article

ActionAutoSubmit does not submit the FlowAction

SA-4499

Summary



When pyActionArea section is used in Perform harness, and has one of the local action as Out-Of-The-Box “ActionAutoSubmit” HTML, it does not submit the flow action.

And, this functionality works fine when “Action” section is used in Perform harness.

Error Messages



None.

Steps to Reproduce



1. Create a FlowAction and use ActionAutoSubmit.
2. Run the flow and choose the Flow Action.
3. The form is not submitted.

Root Cause



The issue is with the code in ActionAutoSubmit HTML.

Resolution



Changed the HTML to JSP and code implemented to execute at server side. The code works for both "pyActionArea" and "Action" sections.

<SCRIPT>
    <%
    String strMessages = tools.getPrimaryPage().getMessagesAll();
        if(strMessages.length() == 0)
        {
            tools.appendString("if(window.name != null && typeof(window.name) != \"undefined\" && window.name == \"actionIFrame\" ){");
                    tools.appendString("pega.util.Event.addListener(window,\"load\",doSubmit);");
            tools.appendString("}else{");
            tools.appendString("doSubmit();}");
        }
    %>
</SCRIPT>
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us