Support Article
Adding a node to SMA fails with "Session expired" error
SA-26501
Summary
Adding a node to System Management Application (SMA) fails with the below error.
User is accessing SMA through URL: http://<your_sma_host.int>:<your_port>/prsysmgmt
Error Messages
com.pega.jmx.ui.util.JMXClientException: Session expired, please login in a new browser window
Steps to Reproduce
Try to add a node to SMA.
Root Cause
A defect or configuration issue in the operating environment. The above error is thrown if an attribute name "initialized" is not set. This attribute is tied to the HTTPServletRequest Session object. In this particular case, subsequent requests from the user's machine were not sending the JSessionID back to the server, thus every request was treated as a new session.
Resolution
Make the following change to the operating environment:
Change the etc/hosts file to include the correct host to IP mapping for the applicable domain.
For example, your_IP was mapped to your_sma_host.com and then SMA was accessed at http://<your_host.com>:<your_port>/prsysmgmt
Published August 12, 2016 - Updated October 8, 2020
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