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Support Article

AddressDetails section NOT displaying to update provider address

SA-18812

Summary



While following the 'Validating the Installation' steps in the 'Pega Customer Service for Healthcare 7.1.3 Installation Guide' within section 3 'Test Provider Services Process', user is unable to complete step 8 on page 33. Step 8 involves a task to update the provider's address.

The ‘AddressDetails’ section IS NOT displaying on screen after selecting the ‘Update Address’ task for a provider phone call request. As a result of the ‘AddressDetails’ section NOT displaying, NO text box fields populate to update the provider address.

This issue with displaying the ‘AddressDetails’ section occurs INTERMITTENTLY in Internet Explorer 11. HOWEVER, the ‘AddressDetails’ section ALWAYS displays in Mozilla Firefox after executing the ‘Update Address’ task.


Error Messages



No error message is displaying on screen.

HOWEVER, the following error message is displaying in the log files:

2015-10-23 15:11:39,352  [TABTHREAD2] [MyCoCPMHCSuper:07.13] (ternal.mgmt.StreamBuilderTools) ERROR CPMHCSysAdmin - Could not find a rule when appending a stream
com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find instance Embed-PegaHC-BEAddress. of type Rule-HTML-Section.

Note: The ‘AddressDetails’ section is in the ‘Embed-PegaHC-BEAddress’ class mentioned above.


Steps to Reproduce



1. Log in to the system using the ID CPMHCMgr and the password install.
2. Select the Phone Call – Provider link on the New menu option on the portal toolbar.
3. When the search screen appears, enter PRAC-1 in the Provider ID search field and press Enter. The matching provider record appears in the Search Results section.
4. Select the provider instance from the result list. Select the Is Contact the Selected Provider check box and click Submit.
5. On the verification screen, choose any of the verification options.
6. Click the '+Add Task' button and click 'Update Address' from the 'Provider' category.
7. Select an address to update. Click 'Update' to make changes to the address data and click 'Submit'. (This is where the problem lies, as there is NO address information to update).
8. Select an address to update. Click Update to make changes to the address data and click Submit.

NOTE: These instructions can be found in the 'Validating the Installation' steps in the 'Pega Customer Service for Healthcare 7.1.3 Installation Guide' within section 3 'Test Provider Services Process.'


Root Cause



A defect in Pegasystems’ code or rules. Basically we are trying to operate on the grid object which is stale and we end up in JS exception.

Resolution



Apply HFix-25526.
 
 

Published January 31, 2016 - Updated October 8, 2020

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