Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

AES 72 SEVERE messages - non-accessible jar during compilation

SA-44025

Summary



“SEVERE” messages are appearing in a fresh Autonomic Event Services (AES) 7.2 environment.

The messages are only in catalina.out and not in PEGA logs or PEGE ALERT logs.


Error Messages


23-Jun-2017 10:18:18.684 SEVERE [http-nio-8080-exec-7] com.pega.pegarules.internal.bootstrap.phase2.loaderfs.PRClasspath. A rule is attempting to use a non-accessible jar during compilation. Please contact GCS to help remove dependencies on non-accessible jars. Attempted to use '/printegrint.jar!/com/pega/pegarules/integration/engine/internal/mapping/xml/XMLParserBase.class
23-Jun-2017 10:18:18.697 SEVERE [http-nio-8080-exec-7] com.pega.pegarules.internal.bootstrap.phase2.loaderfs.PRClasspath. A rule is attempting to use a non-accessible jar during compilation. Please contact GCS to help remove dependencies on non-accessible jars. Attempted to use '/prenginext.jar!/com/pega/pegarules/session/external/mgmt/IPRThread.class
23-Jun-2017 10:18:18.700 SEVERE [http-nio-8080-exec-7] com.pega.pegarules.internal.bootstrap.phase2.loaderfs.PRClasspath. A rule is attempting to use a non-accessible jar during compilation. Please contact GCS to help remove dependencies on non-accessible jars. Attempted to use '/prenginext.jar!/com/pega/pegarules/data/external/clipboard/PageMetaData$I.class
23-Jun-2017 10:18:18.703 SEVERE [http-nio-8080-exec-7] com.pega.pegarules.internal.bootstrap.phase2.loaderfs.PRClasspath. A rule is attempting to use a non-accessible jar during compilation. Please contact GCS to help remove dependencies on non-accessible jars. Attempted to use '/prenginext.jar!/com/pega/pegarules/data/external/clipboard/PageMetaData.class
23-Jun-2017 10:18:18.706 SEVERE [http-nio-8080-exec-7] com.pega.pegarules.internal.bootstrap.phase2.loaderfs.PRClasspath. A rule is attempting to use a non-accessible jar during compilation. Please contact GCS to help remove dependencies on non-accessible jars. Attempted to use '/prenginext.jar!/com/pega/pegarules/session/external/mgmt/IExecutable.class


Steps to Reproduce



Not Applicable


Root Cause



A defect in Pegasystems’ code or rules: Parse-XML rules supplied with AES are deprecated and need to be upgraded.

Resolution



Perform the following local-change:

List all the Parse-XML rules and click the Upgrade button on the Rule after saving them into an Available AESCriteria ruleset.

Suggest Edit

Published November 4, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us