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Support Article

AES case manager portal access

SA-2110

Summary



User is facing issue with accessing AES manager portal and getting requestor timeout whlie accessing portal.

Error Messages



com.pega.pegarules.pub.context.RequestorLockException
com.pega.pegarules.pub.context.RequestorLockException: Unable to synchronize on requestor HFDFF7766704DDAACBCC57672DC0B33D4 within 120 seconds: (thisThread = http-0.0.0.0-9999-294) (originally locked by = http-0.0.0.0-9999-18) (finally locked by = http-0.0.0.0-9999-18)

Steps to Reproduce



Access AES manager portal.


Root Cause



The root cause of this problem is defect/misconfiguration in the PRPC operating environment. There are  2.5 m records in 
pegaam_alert table which is taking time to load in AES Manager portal.

Resolution



This issue is resolved through the following suggestions:


Add DB index.
Keep 1 week data in pegaam_alert and archive remaining.
Add more criteria to reports to minimize the resultset.
Changed the threshold and alerts

 

Published January 31, 2016 - Updated December 2, 2021

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