Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

AES console shows HTTP Response in red frequently (PEGA0005)

SA-4107

Summary



Users experience poor performance of information retrieval in the Pega AES monitor sporadically but frequently during the business processing day. The Pega log file shows no errors, and there are no errors on screen. However, the PEGA0005 alert indicates that database performance is affected.

Error Messages



Database operation took more than the threshold of 500 ms: 602 ms SQL: {call sppr_sys_reservequeueitem_b ( ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) }

Steps to Reproduce



Unknown

Root Cause



The stored procedure sppr_sys_reservequeueitem_b is a known point of poor performance in the environment.

Resolution



To update your copy of the stored procedure sppr_sys_reservequeueitem_b, perform the following local-change to the stored procedure:
  1. Remove the original ORDERBY clause definition
    orderby := ' order by pzInsKey ASC';
  2. Update the ORDERBY clause definition as shown below:
    orderby := ' order by pyMinimumDateTimeForProcessing ASC ';
Suggest Edit

Published August 7, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us