Support Article
AES Portal is not responsive and it keeps on loading
SA-36413
Summary
As part of enterprise health check when user login to the Autonomic Event Services (AES) application deployed on the server instance, the home page keeps on loading and when user click on any red alert or notification, it is not opening and keeps on loading for ever.
Issue is happening in all the browsers.
Error Messages
Thread dump was created and enclosed thread was having the lock:
"http-ABC" Id=137 in TIMED_WAITING on lock=java.util.concurrent.Semaphore$FairSync@4f49247c
BlockedCount : 28732, BlockedTime : -1, WaitedCount : 11884, WaitedTime : -1
at sun.misc.Unsafe.park(Native Method)
at java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:215)
at java.util.concurrent.locks.AbstractQueuedSynchronizer.doAcquireSharedNanos(AbstractQueuedSynchronizer.java:1037)
at java.util.concurrent.locks.AbstractQueuedSynchronizer.tryAcquireSharedNanos(AbstractQueuedSynchronizer.java:1328)
Steps to Reproduce
1. Login to the AES portal.
2. Click Enterprise.
3. After loading the page click on any notification or alert.
Root Cause
On AES instance search indexing was enabled, hence the monitoring nodes were non-responsive.
Resolution
Perform the following local-change to disable the Indexing:
1. Disable search indexing and search functionality on AES by unchecking the main checkbox on the search landing page to "enable indexing".
2. Set the following dynamic system settings to false:
- indexing/distributed/enabled
- indexing/distributed/index_enabled
- indexing/distributed/search_enabled
3. Disable Pega-SearchEngine agent directly on the AES server which call the pzFTSIncrementalIndexer activity, but unchecking “Enable this agent” checkbox.
(Or )
Disable the indexing agent on AES instance from System Management Application (SMA).
Published May 3, 2017 - Updated October 8, 2020
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