Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

After committing hotfixes, they still show as uncommitted

SA-21704

Summary



Unable to commit uncommitted hotfixes in the environment. After clicking Commit button, the status shows All the Hotfixes have been successfully committed. However, when the Hotfix Manager was opened again, hotfixes were still uncommitted.

Error Messages



Not Applicable

Steps to Reproduce



Attempt to commit hotfixes using the Hotfix Manager.

Root Cause



A defect in Pegasystems’ code or rules: The pyUniqueID column on the PR_DATA_PRODUCTS table is too small for all hotfix package names. The maximum size of the column is set to varchar2(16). Because of this, the hotfix package names get truncated to 15 characters and a plus sign (+) in the table effective leading to duplicate rows.

Resolution



Perform the following local-change:
Increase the size of the column to 32 characters. Manually correct any records in the table that have truncated values in the
pyUniqueID column by copying the correct value from the pxInsName column. Once this is complete the hotfix packages may be safely committed from the Hotfix Manager.

Published April 4, 2016 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us