Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

After redirect from revere proxy ,button event is not working.

SA-29479

Summary



A web mashup implementation is displaying an initial harness. The user wants to replace the current harness with a different harness. In the gadget user is setting attributes like "display" with their initial harness name "XYZ". When gateway URL is referring directly to the pega devotement box url then it works but when redirecting through reverse proxy variable, initial harness is loading but any action on button, from that launching another harness is not working.


Error Messages



There is no error message on the screen. However Browser debug mode (F12) there is an error 

HTTP Error 400. The request URL is invalid


Steps to Reproduce

  1. Configure a web mashup implementation.
  2. Display an initial harness and in that harness place a button and on click of that button write code to replace the current harness with a different harness.
  3. Access the Mashup through an top level application hosted on IIS.
  4. After request redirects and displays the initial harness click the button to display the second harness.
  5. The button event doesn't triggers.


Root Cause



A defect or configuration issue in the operating environment. The Browser debug mode confirmed that the IIS is treating the URL invoked on click of the button as invalid and throwing HTTP Error 400. Directly accessing the URL also gave the same error. Some URL size restriction was causing the issue.

Resolution



In order to resolve this issue the administrator added the following registry key as a REG_DWORD: 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters\UrlSegmentMaxLength 

This value defaults to 260, but in the failing requests pega have segments (URL length) of well over that number of characters. user set this value to 2048 and then rebooted the web server for the setting to take effect. 

Published October 27, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us