Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Agent does not execute the activity properly with SMA

SA-10957

Summary



User creates a new agent and adds it to the existing agent ruleset.  The System Management Application(SMA) shows that the Agent is running, but the activity associated with the agent is not executed.

Error Messages



Not Applicable.

Steps to Reproduce

  1. Create a new agent and add it to existing Agent ruleset.
  2. Test whether it is working as per the logic coded in the Agent activity.

Root Cause



The root cause of this problem is a defect in user application code/rules.  The agent is configured as a Standard agent, which means it processes items from a queue.  
There were no queue items present so the activity was not executed.


Resolution



Change the agent mode to Advanced when a queue is not going to be used to process the items.  The Agent then executes the activity each time.
Suggest Edit

Published June 30, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us