Support Article
Agent exception: Unable to reschedule - Invalid delay interval
SA-42419
Summary
It is observed that some agents are taking much longer time to run, progressively increasing since system restarts. Found that, in the node where agents are running, the System Cleaner agent was stopped with the exception:
"2017-08-03 20:00:11,527 [ PegaRULES-Batch-2] [ STANDARD] [ ] [ PegaRULES:07.10] ( internal.async.AgentQueue) ERROR - runEnd(): Code-.SystemCleaner; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -11275".
Several PDN articles say that this comes when the System Cleaner agent is scheduled to run at mid night and the resolution was to schedule to 12:05, but in this case the System Cleaner agent is scheduled at 7 PM, so not sure why this error occurred.
Error Messages
2017-08-03 20:00:11,527 [ PegaRULES-Batch-2] [ STANDARD] [ ] [ PegaRULES:07.10] ( internal.async.AgentQueue) ERROR - runEnd(): Code-.SystemCleaner; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -11275
Steps to Reproduce
Not applicable
Root Cause
Opened the Agent Schedule schedule for the System Cleaner agent. Clicked the Advanced button. The popup windown showed that the agent is configured as Recurring for Every 0 Days.
Resolution
Update the Agent Schedule to Every 1 Days and save.
Review the Agent Schedule for every node.to see if there are any further mis-configurations.
Published August 26, 2017 - Updated October 8, 2020
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