Support Article
Agent Not Behaving Properly
SA-21291
Summary
Agent is going down if large workload (appx 1000-2000) WO are to be processed.
Error Messages
Not Applicable
Steps to Reproduce
1. Create Standard Agent
2. Schedule it to every 30 sec
3. Load test with many WO
4. Agent functionality is not achieved.
Root Cause
An issue in the custom application code or rules: MaxRecords value is blank in agent Configuration. System picks all queue items when Max records value is balnk. When load is very high agent might be takigng more time to process all queue items.
Resolution
Perform the following local-change: Specify MaxRecords value in Agent Configuration.
Published March 24, 2016 - Updated October 8, 2020
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