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Support Article

Agent queue items not visible after upgrade to Pega 7.22

SA-38796

Summary



After the upgrade user is not able to see the queue instance in the App explorer anymore. (All of the System-Queue instances are not visible).

For some of the queue items,the queue instances are not visible.

User requires porting of HFix-30478.

Related bug item is BUG-273903 which was fixed only in Pega 7.3


Error Messages



Not Applicable


Steps to Reproduce



Not Applicable


Root Cause



A defect in Pegasystems’ code or rules.

As there are no pyInstanceList Report definition defined in System-Queue-ServiceLevel class, the instance is picked from @baseclass.

As the columns used in baseclass version are unoptimized for System-Queue-ServiceLevel class, the columns are getting removed from the query.

Hence no data is shown.


Changes made:

The current logic in '@baseclass!pxGetClassKeyNameCaption' sets the 'keyNameCaption' parameter based on pyKeyCaption.

Since the key caption is empty for 'System-Queue-ServiceLevel' class, the Instance list not fetched properly.

​ Modified the activity '@baseclass!pxGetClassKeyNameCaption' Step-4 to use pyKeyName as caption for constructing 'keyNameCaption' parameter if caption is empty.


Resolution


Apply HFix-34630.

Published June 19, 2017 - Updated October 8, 2020

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