Support Article
Agent Schedule is not updated based on the Agent updates
Summary
Agent Schedule is not updated based on the Agent updates.
The user has to delete the Agent schedule to update it each time in the data table and the strategy instance.
Error Messages
Not Applicable.
Steps to Reproduce
- Configure an Agent
- Create an Agent Schedule
- Update the DateTime control in the Agent. The changes do not reflect in the Agent Schedule
Root Cause
Updating the Agent instance (Rule-Agent-Queue) does not automatically update the existing Agent Schedule instance (Data-Agent-Queue).
It is expected to delete the Agent Schedule instance (Data-Agent-Queue) manually which is rebuilt, when the master agent runs if the admin or user wants it to be updated from the Rule-Agent-Queue instance.
RESOLUTION
Business Intelligence Exchange (BIX) extract will fetch only delta of the records based on the last BIX run from the PR_EXTRACT_TIME table, irrespective of the changes to Agent Schedules.
Published August 24, 2018 - Updated October 8, 2020
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