Support Article
Agent is sending duplicate emails
SA-21408
Summary
A custom agent runs once a day and sends an email to some users. The Agent is enabled on all of the nodes. Some users receive two or more emails instead of just a single email.
Error Messages
Not Applicable
Steps to Reproduce
- Create a correspondence and an agent that sends a daily email to all operators that have assignments.
- Enable the agent on all of the nodes.
- Observe that some users receive duplicate emails.
Root Cause
An issue in the custom application code or rules.
Resolution
Perform the following local-change:
Enabling the agent on a single node resolves the issue.
Published April 1, 2016 - Updated October 8, 2020
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