Support Article

Agent slow response issue in production

SA-32206

Summary



In an application, a claim is picked up by a custom agent and handed over to a batch requestor to start processing.

The batch requestor creates the cases and processes it through to resolution.  

This usually takes a short period of time, but sporadically some cases takes a very long time to process.  When it eventually completes, it completes correctly with no errors seen.

Error Messages



Not applicable


Steps to Reproduce



Queue a large number of claims for the custom agent.

Root Cause



An issue in the custom application code or rules where a null value was passed into a report definition, resulting in an entire, large, database table being queried.

Resolution



Perform the following local-change step:  

​Adjust the values being passed to the report definition to avoid null values.

Published January 6, 2017 - Updated January 13, 2017

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