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Agent is unable to find the assignment page for a queued item

SA-15537

Summary



The Queue-For-Agent method is used to queue work items for an agent and resume the flow. The agent activity opens the assignment, checks whether the ResumeParent flow action is present, and calls ResumeFlow if true.

In some instances, the activity is not finding the assignment with the ResumeParent flow action so the ResumeFlow step is skipped in Pega 7.1.7.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create an activity to queue work items to be processed by an agent.
  2. Create an agent that will open the assignment, check for the ResumeParent flow action, and call ResumeFlow if true.


Root Cause



An issue in the custom application code or rules. The Queue-For-Agent step is in the router activity so instances are occurring where the queue item is processed before the work object and workbasket assignment are committed.

Resolution



Perform the following local-change:

Increase the MinimumAgeForProcessing parameter and check the deferred option on the Queue-For-Agent step.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

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