Support Article
Agents do not work after upgrade to Pega 8.2.1
SA-80345
Summary
After upgrading Pega 7.1.9 to Pega 8.2.1, the following issues occur:
- Agents are not in the Running state.
- Errors display when navigating within the Agent and Agent Schedule rule forms.
- Agent Management landing page is not populated.
Error Messages
Status:fail
Operator:Unauthenticated or not available
Node:No ID available
Steps to Reproduce
Execute an agent. Review the Agent and Agent schedule rule forms or access the Agent Management landing page.
Root Cause
A defect or configuration issue in the operating environment.
The Standalone clustering protocol was enabled. This prevented the functionality which leveraged clustering, from operating correctly.
Resolution
Perform the following local-change:
Remove the 'Standalone' or 'None' configuration for the identification/cluster/protocol prconfig setting or adjust its value.
Published August 15, 2019 - Updated December 2, 2021
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