Support Article

Alerts and Exception Purge do not work as expected

SA-26500

Summary



Based on the System settings, alerts and other KPI data is automatically not removed from the system as per the defined retention period.


Error Messages



Not Applicable


Steps to Reproduce

  1. Login to Autonomic Event Services (AES) Manager Portal.
  2. Navigate to Administration Section.
  3. Select the system name under current system drop down on top right.
  4. Click on Purge System Alerts.


Root Cause



A defect or configuration issue in the operating environment At some point in the past the PegaAES agent was not running properly. Alert data accumulated so that normal processing could not take place.

The number of alerts in the DATA.pegaam_alert table had millions of rows. Some as old as 6 months. The retention configured in the AES settings was 14 days.



Resolution



In the database tool of preference delete rows month by month from DATA.pegaam_alert until there are only alerts left with pxCreateDatetime less than 14 days ago.
If exceptions are also not properly groomed then repeat that process with DATA.pegaam_exception.

Published August 5, 2016 - Updated August 23, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.