Support Article
All case statuses not present in dropdown during Bulk Processing
SA-88371
Summary
All the case statuses are not present in the dropdown while performing Bulk Processing.
Error Messages
Attempting to access a rule with a bad defined-on class: Trying to open rule "PYSTATUSWORK!RESOLVED-COMPLAINT" of class "Rule-Obj-FieldValue", but no defined-on class (pyClassName) was specified.
Steps to Reproduce
- Launch the Case Manager portal.
- Select Bulk Processing.
- Press the down arrow key in the dropdown to display the work object status.
Root Cause
An issue in the custom application code or rules.
Custom implementation of the Bulk Process landing page caused the className to be empty for the pzgetWorkStatusesForBulkProcess activity.
Resolution
Perform the following local-change:
- Save As the pzgetWorkStatusesForBulkProcess activity in the custom ruleset used in the custom Bulk Process section.
- Modify Step 1 to set the @baseclass local variable as currentWorkPool.
- Remove the When condition which checks for the out-of-the-box landing page Bulk Action values.
Published October 2, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.