Support Article
Application page missing at service-rest call
SA-45627
Summary
Application page not set for the authenticated application request(REST call) when the service package and authenticating operator have same the Access Group associated.
Error Messages
When traced the tracer shows the error message on page D_Application "No records were found for the lookup with keys : pyProductName= pyProductVersion="
Steps to Reproduce
1. Create an authenticated Rest Service.
2. Provide the same Access Group on the service package and operator.
3. Make the rest call from SOAP UI or Postman.
4. Observe that the Application page is loaded with the App Name and all.
Note: Rest Service only works when there are different access group names under service package and operator.
Root Cause
This issue was determined to be a product enhancement request.
As per the current design when the Access Group on the Service Package and Operator are set with the same service package the system pages like application page are not loaded for the better performance for Application and Batch requests.
Resolution
As per the current PRPC design this is an expected behavior (system pages like application page not being set for the application request) when the service package and the Operator being authenticated are set with the same access group for the better performance.
User is suggested to include different access group (this can be save-as of the access group defined for service package or operator) configured for the operator or service package.
An enhancement request, FDBK-23301, has been created for consideration by Pega Product Management.
Published January 10, 2018 - Updated October 8, 2020
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