Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Application switch issue with Case Worker & Case Manager portal

SA-46939

Summary



Application switch not working properly in Case Worker & Case Manager portal with Pega 7.2.2.
 


Error Messages



Not Applicable


Steps to Reproduce



Scenario: User have access to two application APP A and APP B Behaviour in Case Worker portal of Pega 7.2.2    
  1. Open the Case Manager Portal with APP B
  2. Open the Case let say Case B then it will come under Recent List
  3. Log off the portal
  4. Launch the Portal with Application called APP A
  5. Go to Recent List and Open the Case B then Application is automatically switched to APP B and Case B opened without fail
  6. Now open the Case A then Application is not automatically switched to Application App A
Behaviour in Case Manager portal of Pega 7.2.2    
  1. Open the Case Manager Portal with APP B.
  2. Open the Case let say Case B then it will come under Recent List.
  3. Log off the portal.
  4. Launch the Portal with Application called APP A.
  5. Go to Recent List and Open the Case B then Application is not switched.
                  

Root Cause



In case worker portal after switching the application for the first time "pxCurrentWorkPool" value on "pxRequestor" page still has first application work pool.

Because of this the second time application switch is not happening.

Resolution



Apply HFix-38022 which works only for Case worker portal.

Explanation: Applications can not be switched in case manager portal as it is multi-document portal.

 


 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us