Support Article
Application switch issue with Case Worker & Case Manager portal
SA-46939
Summary
Application switch not working properly in Case Worker & Case Manager portal with Pega 7.2.2.
Error Messages
Not Applicable
Steps to Reproduce
Scenario: User have access to two application APP A and APP B Behaviour in Case Worker portal of Pega 7.2.2
- Open the Case Manager Portal with APP B
- Open the Case let say Case B then it will come under Recent List
- Log off the portal
- Launch the Portal with Application called APP A
- Go to Recent List and Open the Case B then Application is automatically switched to APP B and Case B opened without fail
- Now open the Case A then Application is not automatically switched to Application App A
- Open the Case Manager Portal with APP B.
- Open the Case let say Case B then it will come under Recent List.
- Log off the portal.
- Launch the Portal with Application called APP A.
- Go to Recent List and Open the Case B then Application is not switched.
Root Cause
In case worker portal after switching the application for the first time "pxCurrentWorkPool" value on "pxRequestor" page still has first application work pool.
Because of this the second time application switch is not happening.
Resolution
Apply HFix-38022 which works only for Case worker portal.
Explanation: Applications can not be switched in case manager portal as it is multi-document portal.
Published July 23, 2018 - Updated October 8, 2020
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