Support Article

"application/file" from Connect-HTTP rendering badly

SA-33822

Summary



User wrote the Java step to decode the base64 encoded repsonse from Connect-Http and trying to decode using the send file Java API.

But user is getting this report as a downloaded file which is not justifying the business use case.

User also tried the Pega Out-of-the-box (OOTB) base64decode function to get the same but it results in loss of format.

F
ormat of the response is lost . There is no new line and space format in the report.


Error Messages



Not Applicable

Steps to Reproduce



Not Applicable


Root Cause



User was not writing the correct java step.

User first tried it to get logged in the Pega Rules to see how it is showing in the Pega rules.

It was coming properly so one copied it to clipboard using a local string type variable.


Resolution



User is recommended to use the Text Area control other than any other control like Rich text editor, as the format is lost.

Still the issue is, according to business use case this report should not be editable and in read only edit options we will loose the format.

For those queries asked user to raise a Product Support Community post and parallely and also a new SR to answer these queries why there is loss of format while using the TestArea control with readonly edit option.

Published February 16, 2017 - Updated March 4, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.