Support Article
Assigned count colour does not change
SA-10373
Summary
User noticed that in user Portal, count urgency assigned by team members does not change.
Error Messages
Not Applicable.
Steps to Reproduce
Open User Portal,check the assigned count urgency of all the team members.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules.
In the Case Manager portal, pyUserAssignmentCountByUrgency report defination is used to show the assigned count urgency of users.
This report definition checks the pxGoalExecute/pxDeadlineExetute fields of assignments to find out whether for any assignment the Goal/Deadline time has been passed or not.
The pxGoalExecute/pxDeadlineExetute fields are set by an agent depending upon the Goal/Deadline time.
However, this agent cannot set these fields if the assignment is locked by any user and thus user Portal team members assigned count urgency does not change.
Resolution
This issue is resolved through the following local change:
1. Write a function alias (call it checkIfPositive in Embed-UserFunction class) like below

2. In pyUserAssignmentCountByUrgency, instead of goal/deadline execute use this function and summarize on max.

3. Each checkifpositive function should call difference in minutes for goal/deadline execute and current datetime.


4. In pyOperatorsByWorkGroup report definition, re-check and re-save the reference of sub-report pyUserAssignmentCountByUrgency.
Published June 10, 2015 - Updated October 8, 2020
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