Support Article
Assignment processing error
SA-9557
Summary
When a user attempts to process a work object while the server is being restarted or a service is not available, the work object is routed to the ConnectionProblem flow. The assignment link displayed is "Process: ConnectionProblem - Assigned To: - Next Step: Service Unavailable". An error occurs when trying to open this assignment to resume the flow.
Error Messages
Unable to open an instance using the given inputs: ASSIGN-WORKBASKET SAMPLE-WORK W-1!CONNECTIONPROBLEM
ContactSysAdminForAssignRepair
Steps to Reproduce
Process a work object when the server is restarted or access a particular flow when the corresponding service is unavailable.
Root Cause
The ConnectionProblem flow routes the assignment to the IncompleteConnections workbasket, which has a service level rule to retry the work object. The agent was unable to process the item so a broken queue item was generated and the assignment was included on the Workbasket Assignment Errors report. The Administrator reviewing the assignment errors deleted the assignment.
Resolution
Instead of deleting the error assignment, the Administrator should open the assignment in the IncompleteConnections workbasket and select the appropriate flow action to resume or cancel the flow.
Published June 12, 2015 - Updated October 8, 2020
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