Support Article
Assignment SLA does not work for ScreenFlow
SA-95160
Summary
SLA does not work for the ScreenFlow. The Initial Urgency is added twice when the Goal time is reached.
Error Messages
Not Applicable
Steps to Reproduce
- Create a Flow rule which has a sub-process shape followed by assignments.
- Create a screen flow.
- Invoke the screen flow from the main flow.
- Set the SLA at the flow level and the work object level.
- Execute the test case.
Root Cause
When the Goal time is reached, the initial Urgency is added multiple times to the work object Urgency. In the ExecuteSLA activity, the pxUrgencyWork is calculated at Step13,
pxUrgencyWork - Calculated as pxUrgencyWorkClass+pxUrgencyWorkSLA+pxUrgencyWorkStepSLA
pxUrgencyWorkClass - Default value is 10
pxUrgencyWorkSLA - Calculated as sla.pyUrgencySLA(initial urgency in SLA) + sla.pyEscalations(Goal).pyEscalationUrgency (Goal time Urgency increase count)
pxUrgencyWorkStepSLA - Initial urgency when this step reached. This already contains the initial urgency of the SLA rule. Hence, the initial urgency is added twice.
Resolution
Perform the following local change:
- Avoid using the Initial Urgency for the flow.
- Declare Expression - pxUrgencyWork is an Available rule and can override the pxUrgencyWork declare expression rule to build an expression which is suitable according to the requirement. Removing the pxUrgencyWorkStepSLA from the expression must provide a result that is similar to the working of the stage SLA.
An enhancement request, FDBK-64151, is created for consideration by Pega Product Management.
Published January 2, 2020 - Updated October 8, 2020
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