Support Article
Association tab of knowledge content rule does not get populated
SA-23470
Summary
A knowledge content rule and its corresponding association rule are created. The Association tab of knowledge content rule still shows empty records.
Error Messages
Not Applicable
Steps to Reproduce
1. Create knowledge content rule.
2. Create Association rule.
Root Cause
Associations tab is populated by the listview Index-PegaCA-Association-KnowledgeContent.CAAssociationList ALL
However, Index-PegaCA-Association-KnowledgeContent class does not list instances, Association rules added to the system, in question.
Whenever a knowledge content association rule is created, it is saved as an instance of Rule-PegaCA-Association-KnowledgeContent class. A declare index Rule-PegaCA-Association-KnowledgeContent • Associations (Index class to write : Index-PegaCA-Association-KnowledgeContent) will be fired, which creates an index (entry into pca_index_assoc_knowcont table).
Since the respective indexes are not present, indexes must be manually recreated by running out-of-the-box activity RecreateIndexesForClass.
Further analysis of the issue revealed that the declare index is saved into custom ruleset and marked as “blocked,” which is the root cause of the issue.
Resolution
Refer to out-of-the-box declare index or Save As the out-of-the-box declare index to application ruleset. Delete the custom blocked rule, so that the system will always pick up the out-of-the-box declare index.
Published May 19, 2016 - Updated December 2, 2021
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