Support Article
Attachement are not removed from server tmp folder
SA-35334
Summary
CMIS integration does not delete files from server PegaTMP directory as expected after user views documents from case. No error in logs and functionality works as expected but server memory is being occupied drastically as all documents get stored on disk.
Error Messages
Not applicable.
Steps to Reproduce
- Enable CMIS integration with Alfresco
- Attach any document to case, document will be save to alfresco or CMIS repository.
- Open the document from case
- Document get stored in server tmp folder(CMIS_Folder)
- Document remains in tmp folder.
Root Cause
This is expected behavior.
Resolution
Perform cleanup using activity modeled after StaticContentCleanup and employing approach shown in following PDN article.
https://pdn.pega.com/support-articles/remove-file-service-export-directory
Published March 26, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.