Support Article

Auto Complete functionality is not working

SA-28281

Summary



User is on Pega Customer Service 6.3 SP1  or PRPC 6.3 SP1. 

User has an autocomplete functionality for UI, before applying filter, all the records is showing, but after apply the filter, the records not showing exact records, which is in clipboard page


Error Messages



Not applicable


Steps to Reproduce



1) Auto Complete mapped in UI and in below repeating grid have been placed, once selected the item from autocomplete and click on button the selected items(1,2,3...) will be set in below as a repeat, like wise put 2 dates from date and To date.
2) In the Property Control used to provide data control from clipboard.
3) After placing a button, call activity to trigger once selected the dates from and date to, the data will be filtered and based on dates and filtered data should be appeared in the auto complete, filtered data appeared in clip board but not in Auto complete.


Root Cause



The clipboard values are updating properly. But in auto complete all the values are being returned. 

Found to be issue with client cache being checked in the control. 

Select this Client Cache check box to cause listed results to be cached temporarily on the client workstation, for faster access upon a second similar request.

Leave cleared if the listed results are highly dynamic.

Resolution

Since the results here are dynamic, clearing the 'Client Cache' resolves the issue.

Published September 22, 2016 - Updated October 3, 2016


0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.