Support Article

AVAYA API version is not getting updated

SA-30617

Summary



As part of the Avaya Upgrade project to upgrade AVAYA to version 7 and
Webshpere 7.0.0.27, user runs into an issue.

After the import of the PEGACALL jar and ecsjtapia jar provided by AVAYA for AVAYA version 7, the AVAYA API version is not getting updated but the PEGA CALL version and Channel services version is properly updated.

User have implemented the following :

1. Set the DSS value of Softphone/Jtapi/Enable14 to true
2. Set the DSS value of Softphone/Mode/Stateful to true.
3. Import PEGACALL_7134 jar.
4. Import the latest JTAPI (ecsjtapia.jar) file provided by AVAYA (The JAR version of ecsjtapia jar reports as 7.x).
5. Clean restarted the server.

The PEGACALL Engine and PEGA Channel services Codeset has been updated correctly to 7.1.34.882 and 07-13-04 respectively but the AVAYA API version still shows 5.2.0.431

User has tried truncating the cache tables and deleting the entries of the ecsjtapia.jar file from the pr_engineclasses table and then restarted the server by deleting the temp directory and still the older version of AVAYA API is being displayed.



Error Messages

No. The old AVAYA API version is getting displayed.


Steps to Reproduce



1. Import PEGA CAll jar.
2.Import ecsjtapia jar provided by AVAYA for AVAYA version 7. (The JAR version of ecsjtapia jar reports as 7.x)
3. Restart the server after deleting the temp directory.
4. Check the AVAYA API version in the PEGA CALL landing page in PEGA.


Root Cause



The Avaya 6 version of ecsjtapia.jar must be removed from the environment prior to importing the Avaya 7 version of the jar.

Resolution



Perform the following local-change: 

1)      Query the pr_engineclasses table select * from pr_engineclasses where (pzjar = 'ecsjtapia.jar') this should return 0 rows. If not they should delete the row.
2)      Query the pr_engineclasses table select * from pr_engineclasses where (pzclass = 'ecsjtapia.jar') this should return 0 rows. If not they should delete the row.
3)      Start or restart the app server. If the version is still wrong, repeat the above queries. If they return 0 rows then the file is somewhere on the file system and they need to find and delete it.
4)      Import the Avaya 7 Version of ecsjtapia.jar.
 
The Pega 7 platform ships with a default codeset version of 06-01-01 for 3rd party or customer jars. This value needs to match that to which the jar was deployed. If there are other customer jars they too need to match as ​there is only one customer codeset value and all customer jars need to be in that codeset.

 

 

Published November 21, 2016 - Updated November 28, 2016

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