Support Article

Background not highlighted for icons

SA-32775

Summary



Background is not getting highlighted for icons when accessibility is turned on.


Error Messages



Not Applicable


Steps to Reproduce

  1. Login CLMSysAdmin/install.
  2. Turn on accessibility.
  3. Launch CaseManager portal.
  4. Tab until we reach operator icon.
  5. Observe that icon background is not highlighted.


Root Cause



An issue in the custom application code or rules

With accessibility on, when the user launches CaseManager portal and use TAB key to navigate. Whenever icons and buttons are encountered, they aren't highlighted (in our standard yellow color). Upon verifying the code in desktopaccessibility js, Pega is specifically avoiding highlighting of Buttons and Icons.

Resolution



Perform the following local-change:

Below is the workaround to highlight icons only. (Buttons will not be highlighted)


Code snippet:

<script>
if(pega.u.d.isAccessible) {
$(document).ready(function() {

var iconsList = $('i.icons');
var iconItr =0;

for(;iconItr<iconsList.length;iconItr++){
pega.util.Event.addListener(iconsList[iconItr], "focus", d_highlightField);
pega.util.Event.addListener(iconsList[iconItr], "blur", d_unHighlightField);
}
});
}
</script>



Please have this code included in an non-auto generated section and include that section in the pyPortalHeader.


Published January 23, 2017 - Updated January 31, 2017


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