Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Batch Execution is very Slow in MS SQL Server

SA-9121

Summary



Batch Execution is very slow in CDM68 compared to CDM61. Same batch for 500,0000 records in CDM v6.1 execution completed in 25 minutes and in CDM v6.8 it has taken more than 4 hours and approximately 1% of output completed.

Error Messages



Not Applicable

Steps to Reproduce



Execute the batch in CDM68.

Root Cause



The parameter sendStringParametersAsUnicode in weblogic server console for the MS SQL JDBC drivers defaults to 'true’ which makes the driver send every string in Unicode format to the database by default. If the database tables use only the ASCII data types, you must disable this property to ensure the following:
  • All parameters of the JDBC statements are sent to the database in ASCII format thereby getting rid of Unicode conversion overhead.
  • All indexes are actively used during data fetches thereby getting rid of whole table scans.

Resolution



Set the parameter sendStringParametersAsUnicode to false in the datasource configuration connecting to SQL Server in the weblogic admin console.
Suggest Edit

Published June 12, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us