Support Article
BeginQuiesce is generated in the log
SA-64755
Summary
A system (test) on PegaCloud stops working and a node is terminated. BeginQuiesce is generated in the log.
Error Messages
In PegaRULES.log,
[http-apr-8091-exec-8] [STANDARD] [ ] [ ] (pega.highavailability.quiesce) INFO - [BeginQuiesce] This node has started the quiesce process. Mode: immediateDrain
[33fa2e2a0f26.event-5] [STANDARD] [ ] [ ] (til.HazelcastMembershipManager) INFO - Cluster member left: Member: [name=abcdefg, address=ip-aa-bbb-c-5/127.0.0.1:xxxx, uuid=aaaaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeee, mode=SERVER]
[33fa2e2a0f26.event-5] [STANDARD] [ ] [ ] (senceClusterMembershipListener) INFO - Clearing presence record sessions for node: abcdefg
[33fa2e2a0f26.event-5] [STANDARD] [ ] [ ] (.util.ClusterMembershipManager) INFO - Members [1] {
[33fa2e2a0f26.event-5] [STANDARD] [ ] [ ] (.util.ClusterMembershipManager) INFO - Member: [name=abcdefg, address=ip-aa-bbb-c-5/127.0.0.1:xxxx, uuid=aaaaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeee, mode=SERVER] <== THIS node
[33fa2e2a0f26.event-5] [STANDARD] [ ] [ ] (.util.ClusterMembershipManager) INFO - }
Steps to Reproduce
Not Applicable
Root Cause
This behavior is as per Pega product design.
Resolution
Here’s the explanation for the reported behavior:
In PegaCloud, the Health Check mechanism ensures that the server nodes are running in Acceptable performance. If a node does not respond to a Health Check message within the threshold time frame, the node is re-initiated automatically.
Published October 17, 2018 - Updated October 8, 2020
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