Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

BIX does not extract all records to CSV file

SA-95760

Summary



Business Intelligence Exchange (BIX) does not extract all the records to the CSV file through command line jobs.


Error Messages



Not Applicable    


Steps to Reproduce

  1. Install Business Intelligence Exchange 
  2. Create Extract rule for CSV 
  3. Run the command line using -u(start time) and -U(end time) parameters
  4. Specify the timezone
  5. Compare the number of instances extracted in log files to the files. The instances extracted would be less


Root Cause



Default order of extraction is on pzinskey. However, -n parameter must be added as it may cause performance hit. The commandline extract hangs due to processing of a corrupt instance as it goes into an infinite loop.


Resolution

  1. Apply HFix-58813
  2. Apply HFix-58849 




 

Suggest Edit

Published December 6, 2019 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us