Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

BIX does not update existing extracted records

SA-38545

Summary



BIX does not update existing extracted records.


Error Messages



Not Applicable


Steps to Reproduce

  1. Run Extract rule
  2. View data in output database table


Root Cause



The behavior is working as designed.

Resolution



BIX does not update existing records, instead inserts new ones. This is because the primary purpose of BIX is for reporting data. It is assumed that a report is run after each time BIX is run, preventing duplicates in the report.

Published July 14, 2017 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us