Support Article
BIX Extract fails with authentication error
SA-43744
Summary
When running BIX Extracts from an agent that calls a custom activity that calls pxExtractDataWithArgs, the extracts fail with an authentication error.
Error Messages
[PegaRULES-Batch-9] [STANDARD] [ ] [SA:01.01.01] (internal.mgmt.Executable) ERROR - Only authenticated client may start this activity: RULE-OBJ-ACTIVITY RULE-ADMIN-EXTRACT your_activity #20170904T031403.616 GMT ReqID=B40242EC2D6A75EA4F3707C12266C2ED5
com.pega.pegarules.pub.PRRuntimeException: Error: You lack access required to execute RULE-OBJ-ACTIVITY RULE-ADMIN-EXTRACT RUNBIXEXTRACTS #20170904T031403.616 GMT.
at com.pega.pegarules.session.internal.mgmt.Executable.updateStepStatusAndLog(Executable.java:874)
at com.pega.pegarules.session.internal.mgmt.Executable.activityProlog(Executable.java:80
Steps to Reproduce
Configure an agent to call a custom activity that calls pxExtractDataWithArgs.
Root Cause
An issue in the custom application code or rules. The agent and activity are configured incorrectly and do not allow the agent to run the activity.
Resolution
Perform the following local-change:- Verify that the agent has an access group set.
- Enable ‘bypass activity authentication’ on the security tab of the agent rule form.
- On the activity called by the agentDisable ‘Require Authentication to Run’ on the security tab of the rule form.
Published October 26, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.