Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

BIX extract "No Instance found in the database" error

SA-15742

Summary



Run an Extract Rule from the developer portal, the error "No Instance found in the database" is received.


Error Messages



No Instance found in the database.

bix/useHistoryClasses setting has been disabled
Value of pyLastUpdateDate in pr_Extract_Time at the beginning of BIX run: 2015-09-22 00:00:00.0
SQL Exception: Unsupported holdability value
     #Instances this thread updated: 0
     CPU Time (this thread): 0.0 seconds


Steps to Reproduce

  1. Create an extract rule
  2. Select CSV as the extract output format
  3. Delete all filter criteria and check "Use Last Updated time as Start"
  4. Run extract

 


Root Cause



A third-party product issue. There is a compatibility problem with this version of BIX and up level versions of the Oracle JDBC driver.

Resolution



Make the following change to the operating environment: 
Use an earlier version of the JDBC driver to circumvent this problem.
See reference:
ResultSet.HOLD_CURSORS_AT_COMMIT holdability value is not supported in Oracle JDBC driver version: 12.1.0.1.0. 

 

Published January 31, 2016 - Updated December 2, 2021

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us